Preview degradation
Incident Report for Siteleaf
Resolved
This incident has been resolved.
Posted Nov 24, 2020 - 02:57 UTC
Monitoring
We have identified intermittent issues with site previews. A fix has been implemented and we will continue to monitor.
Posted Nov 23, 2020 - 21:52 UTC
This incident affected: Site Previews.